summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorlucas <luben93@gmail.com>2020-01-26 16:40:45 +0100
committerlucas <luben93@gmail.com>2020-01-26 16:40:45 +0100
commit61284527048c0a9caeea81ff0da92d2c1adedfd7 (patch)
tree6288b89ae010495e305ea420ed0fc67be5b92264 /CMakeLists.txt
parent37d50ed62bd3ff396ac37a23a923a6fcf0f25cad (diff)
cleaned up openocd cmake options and added a readme
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6e2ddeac..9bf80a53 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -31,6 +31,12 @@ if(USE_GDB_CLIENT)
endif()
endif()
+if(USE_OPENOCD)
+ if(NOT OPENOCD_BIN_PATH)
+ set(OPENOCD_BIN_PATH "openocd")
+ endif()
+endif()
+
message("BUILD CONFIGURATION")
message("-------------------")
message(" * Version : " ${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${PROJECT_VERSION_PATCH})
@@ -44,7 +50,7 @@ elseif(USE_GDB_CLIENT)
message(" * Programmer/debugger : GDB Client")
message(" * GDB Client path : " ${GDB_CLIENT_BIN_PATH})
message(" * GDB Target : " ${GDB_CLIENT_TARGET_REMOTE})
-elseif(USE_OPENOCD_CLIENT)
+elseif(USE_OPENOCD)
message(" * Programmer/debugger : OpenOCD Client")
endif()