summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJean-François Milants <jf@codingfield.com>2022-09-17 21:17:01 +0200
committerJF <JF002@users.noreply.github.com>2022-09-17 21:25:54 +0200
commit6ed8e983e96afea0fc42f06d43ff5927728d9f6b (patch)
treee8695771e8fbc6308db7183c3c5f4ebf7f66efb6 /CMakeLists.txt
parentc853681d753c7ca8e2fe7bb22ca046f46ec47460 (diff)
Remove CMake targets and corresponding CLI arguments that are specific to the debugging environment (USE_JLINK, USE_OPENOCD and USE_GDB_CLIENT).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt33
1 files changed, 0 insertions, 33 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1da460c4..75a6baa5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,28 +24,6 @@ if (NOT NRF5_SDK_PATH)
message(FATAL_ERROR "The path to the NRF52 SDK must be specified on the command line (add -DNRF5_SDK_PATH=<path>")
endif ()
-if(USE_JLINK)
- if (NOT NRFJPROG)
- message(FATAL_ERROR "the path to the tool nrfjprog must be specified on the command line (add -DNRFJPROG=<path>")
- endif ()
-endif()
-
-if(USE_GDB_CLIENT)
- if(NOT GDB_CLIENT_BIN_PATH)
- set(GDB_CLIENT_BIN_PATH "arm-none-eabi-gdb")
- endif()
-
- if(NOT GDB_CLIENT_TARGET_REMOTE)
- message(FATAL_ERROR "The GDB target must be specified (add -DGDB_CLIENT_TARGET_REMOTE=<target>")
- endif()
-endif()
-
-if(USE_OPENOCD)
- if(NOT OPENOCD_BIN_PATH)
- set(OPENOCD_BIN_PATH "openocd")
- endif()
-endif()
-
if(DEFINED USE_DEBUG_PINS AND USE_DEBUG_PINS)
add_definitions(-DUSE_DEBUG_PINS)
endif()
@@ -81,17 +59,6 @@ message(" * Toolchain : " ${ARM_NONE_EABI_TOOLCHAIN_PATH})
message(" * GitRef(S) : " ${PROJECT_GIT_COMMIT_HASH})
message(" * NRF52 SDK : " ${NRF5_SDK_PATH})
message(" * Target device : " ${TARGET_DEVICE})
-set(PROGRAMMER "???")
-if(USE_JLINK)
- message(" * Programmer/debugger : JLINK")
- message(" * NrfJprog : " ${NRFJPROG})
-elseif(USE_GDB_CLIENT)
- message(" * Programmer/debugger : GDB Client")
- message(" * GDB Client path : " ${GDB_CLIENT_BIN_PATH})
- message(" * GDB Target : " ${GDB_CLIENT_TARGET_REMOTE})
-elseif(USE_OPENOCD)
- message(" * Programmer/debugger : OpenOCD Client")
-endif()
if(USE_DEBUG_PINS)
message(" * Debug pins : Enabled")
else()