summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJF <jf@codingfield.com>2020-01-26 19:25:28 +0100
committerJF <jf@codingfield.com>2020-01-26 19:25:28 +0100
commita3ff41705e5dde48aab2c4fb2cb80f2144562648 (patch)
treeb496dacce0c0e3e7f5582828533396ac0ee55a9a /CMakeLists.txt
parent7c03810f46ff1f7accd2f5adb7404b4f2cb723d9 (diff)
parent61284527048c0a9caeea81ff0da92d2c1adedfd7 (diff)
Merge branch 'messing-with-openocd' of https://github.com/luben93/Pinetime into luben93-messing-with-openocd
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 11 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a8d8426b..79b3dbe9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,9 +11,9 @@ if (NOT NRF5_SDK_PATH)
message(FATAL_ERROR "The path to the NRF52 SDK must be specified on the command line (add -DNRF5_SDK_PATH=<path>")
endif ()
-if(NOT USE_JLINK AND NOT USE_GDB_CLIENT)
- set(USE_JLINK true)
-endif()
+#if(NOT USE_JLINK AND NOT USE_GDB_CLIENT)
+# set(USE_JLINK true)
+#endif()
if(USE_JLINK)
if (NOT NRFJPROG)
@@ -31,6 +31,12 @@ if(USE_GDB_CLIENT)
endif()
endif()
+if(USE_OPENOCD)
+ if(NOT OPENOCD_BIN_PATH)
+ set(OPENOCD_BIN_PATH "openocd")
+ endif()
+endif()
+
message("BUILD CONFIGURATION")
message("-------------------")
message(" * Version : " ${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${PROJECT_VERSION_PATCH})
@@ -44,6 +50,8 @@ elseif(USE_GDB_CLIENT)
message(" * Programmer/debugger : GDB Client")
message(" * GDB Client path : " ${GDB_CLIENT_BIN_PATH})
message(" * GDB Target : " ${GDB_CLIENT_TARGET_REMOTE})
+elseif(USE_OPENOCD)
+ message(" * Programmer/debugger : OpenOCD Client")
endif()
set(VERSION_EDIT_WARNING "// Do not edit this file, it is automatically generated by CMAKE!")