summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristoph Honal <christoph.honal@web.de>2022-05-10 22:11:08 +0200
committerJF <JF002@users.noreply.github.com>2022-06-19 21:23:59 +0200
commite247afaa81a6011b61ea4a7cfdbd84fadbe29b4b (patch)
tree5ffbce84a5862141fd94658a18e3f47838d69208 /CMakeLists.txt
parent61c2d8dbc77ad909910a28406081e38c72150fce (diff)
CMake: Extend debug configuration
Enable debug output for InfiniTime, Nimble and the NRF SDK via SEGGER RTT on debug builds.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f6aaf62a..acd48698 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,7 @@
cmake_minimum_required(VERSION 3.10)
+
+set(CMAKE_BUILD_TYPE Release CACHE STRING "Choose Debug or Release")
+
project(pinetime VERSION 1.9.0 LANGUAGES C CXX ASM)
set(CMAKE_C_STANDARD 99)
@@ -70,8 +73,10 @@ string(STRIP "${PROJECT_GIT_COMMIT_HASH}" PROJECT_GIT_COMMIT_HASH)
message("PROJECT_GIT_COMMIT_HASH_SUCCESS? " ${PROJECT_GIT_COMMIT_HASH_SUCCESS})
+message("")
message("BUILD CONFIGURATION")
message("-------------------")
+message(" * Mode : " ${CMAKE_BUILD_TYPE})
message(" * Version : " ${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${PROJECT_VERSION_PATCH})
message(" * Toolchain : " ${ARM_NONE_EABI_TOOLCHAIN_PATH})
message(" * GitRef(S) : " ${PROJECT_GIT_COMMIT_HASH})