summaryrefslogtreecommitdiff
path: root/cmake-nRF5x/example/CMakeLists.txt
diff options
context:
space:
mode:
authorJF <jf@codingfield.com>2019-11-17 20:47:04 +0100
committerJF <jf@codingfield.com>2019-11-17 20:47:04 +0100
commit2ea27e0cdac91cd4743d9f12496bb3f911d9efa9 (patch)
treeae6488be1be14c2b83aff6e69a6e622088fb093a /cmake-nRF5x/example/CMakeLists.txt
Initial commit
Diffstat (limited to 'cmake-nRF5x/example/CMakeLists.txt')
-rw-r--r--cmake-nRF5x/example/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/cmake-nRF5x/example/CMakeLists.txt b/cmake-nRF5x/example/CMakeLists.txt
new file mode 100644
index 00000000..9d002518
--- /dev/null
+++ b/cmake-nRF5x/example/CMakeLists.txt
@@ -0,0 +1,18 @@
+cmake_minimum_required(VERSION 3.12)
+
+set(NRF_TARGET nrf52)
+
+if (NOT DEFINED ARM_NONE_EABI_TOOLCHAIN_PATH)
+ set(ARM_NONE_EABI_TOOLCHAIN_PATH "/usr/local/bin")
+endif ()
+
+set(NRF5_SDK_PATH "${CMAKE_CURRENT_LIST_DIR}/../../toolchains/nRF5/nRF5_SDK")
+set(NRFJPROG "${CMAKE_CURRENT_LIST_DIR}/../../toolchains/nRF5/nrfjprog/nrfjprog")
+
+include("${CMAKE_CURRENT_LIST_DIR}/../CMake_nRF5x.cmake")
+
+nRF5x_toolchainSetup()
+
+project(ExampleProject C)
+
+add_subdirectory(src) \ No newline at end of file