summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorChristoph Honal <christoph.honal@web.de>2022-06-27 08:34:01 +0200
committerJF <JF002@users.noreply.github.com>2022-07-07 11:23:05 +0200
commit463355281a21cfe380aef2068cf765a867b6ad01 (patch)
tree1372ad28d1518b618527e7dc4920bc71549966ba /src/CMakeLists.txt
parent0f1e5105740b08d5033737accc6922bad90fb825 (diff)
Display target build variant in system info screen
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index aa06b2b3..967d498b 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -788,6 +788,7 @@ add_definitions(-DMYNEWT_VAL_BLE_LL_RFMGMT_ENABLE_TIME=1500)
# Target hardware configuration options
add_definitions(-DTARGET_DEVICE_${TARGET_DEVICE})
+add_definitions(-DTARGET_DEVICE_NAME="${TARGET_DEVICE}")
if(TARGET_DEVICE STREQUAL "PINETIME")
add_definitions(-DDRIVER_PINMAP_PINETIME)
add_definitions(-DCLOCK_CONFIG_LF_SRC=1) # XTAL