summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJF <jf@codingfield.com>2020-10-19 21:46:41 +0200
committerJF <jf@codingfield.com>2020-10-19 21:46:41 +0200
commit55427d83b87960903cd6213ac9c73e694ee547bd (patch)
tree11604c13579de52016ca1b490ca212e016fd1916 /src/CMakeLists.txt
parent28bc4344193cda2936ff0f69ae51aa79a7840998 (diff)
[WIP] Add new notification UI that use HW scrolling effects. Both notification apps are available in the menu, we can compare them.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 4647e92d..36c69311 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -342,6 +342,7 @@ list(APPEND SOURCE_FILES
displayapp/screens/FirmwareValidation.cpp
displayapp/screens/ApplicationList.cpp
displayapp/screens/Notifications.cpp
+ displayapp/screens/Notifications_swscroll.cpp
main.cpp
drivers/St7789.cpp
drivers/SpiNorFlash.cpp
@@ -420,7 +421,8 @@ set(INCLUDE_FILES
displayapp/screens/FirmwareValidation.h
displayapp/screens/ApplicationList.h
displayapp/Apps.h
- displayapp/screens/Notifications.h
+ displayapp/screens/Notifications.h
+ displayapp/screens/Notifications_swscroll.h.h
drivers/St7789.h
drivers/SpiNorFlash.h
drivers/SpiMaster.h
@@ -749,7 +751,6 @@ elseif (USE_OPENOCD)
COMMENT "flashing ${EXECUTABLE_NAME}.hex"
)
else ()
- message()
add_custom_target(FLASH_ERASE
COMMAND ${OPENOCD_BIN_PATH} -f interface/stlink.cfg -c 'transport select hla_swd' -f target/nrf52.cfg -c init -c halt -c 'nrf5 mass_erase' -c reset -c shutdown
COMMENT "erasing flashing"