summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJF <jf@codingfield.com>2019-12-07 17:11:50 +0100
committerJF <jf@codingfield.com>2019-12-07 17:11:50 +0100
commit6fbb6c8f70b2103fd88d8d9da3ce884a283b1bfd (patch)
tree000f0851f3517b9b8a40c16d4c6bf34fd834b24c /src/CMakeLists.txt
parent0db16bd8279826878e9d2d5ba63e21c4e15c35bf (diff)
Convert Spi and GFX to C++.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index fb34595b..d2ba5e25 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -33,8 +33,9 @@ list(APPEND SOURCE_FILES
DisplayApp/DisplayApp.cpp
DisplayApp/lcdfont.c
main.cpp
- drivers/st7789.cpp
- drivers/spi_master_fast.cpp
+ drivers/St7789.cpp
+ drivers/SpiMaster.cpp
+ Components/Gfx/Gfx.cpp
)
set(INCLUDE_FILES
@@ -43,8 +44,9 @@ set(INCLUDE_FILES
BlinkApp/BlinkApp.h
DisplayApp/DisplayApp.h
DisplayApp/lcdfont.h
- drivers/st7789.h
- drivers/spi_master_fast.h
+ drivers/St7789.h
+ drivers/SpiMaster.h
+ Components/Gfx/Gfx.h
)
nRF5x_addExecutable(pinetime-app "${SOURCE_FILES}") \ No newline at end of file