summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAdam Pigg <adam@piggz.co.uk>2020-07-11 21:41:20 +0100
committerAdam Pigg <adam@piggz.co.uk>2020-07-11 21:41:20 +0100
commit789e06fdb77704fa5da12355ad5f1d8c9d4455e5 (patch)
tree56972f902675749e0df58e91d8670dd5215d677e /src/CMakeLists.txt
parent7a1e6e6e5bf187846bd533f04ee58e04798f0035 (diff)
parent6309719a62436fd746a7a8b228205e93b419ca26 (diff)
Merge branch 'develop' of https://github.com/JF002/Pinetime into music
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 8c702b8e..b379c781 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -44,7 +44,7 @@ set(SDK_SOURCE_FILES
# FreeRTOS
${NRF5_SDK_PATH}/external/freertos/source/croutine.c
${NRF5_SDK_PATH}/external/freertos/source/event_groups.c
- ${NRF5_SDK_PATH}/external/freertos/source/portable/MemMang/heap_1.c
+ ${NRF5_SDK_PATH}/external/freertos/source/portable/MemMang/heap_4.c
${NRF5_SDK_PATH}/external/freertos/source/list.c
${NRF5_SDK_PATH}/external/freertos/source/queue.c
${NRF5_SDK_PATH}/external/freertos/source/stream_buffer.c
@@ -365,7 +365,7 @@ list(APPEND SOURCE_FILES
${TINYCRYPT_SRC}
${NIMBLE_SRC}
${LVGL_SRC}
- ${IMAGE_FILES}
+ #${IMAGE_FILES}
${SDK_SOURCE_FILES}
DisplayApp/LittleVgl.cpp
@@ -444,6 +444,8 @@ set(INCLUDE_FILES
libs/date/includes/date/tz_private.h
DisplayApp/LittleVgl.h
SystemTask/SystemTask.h
+ SystemTask/SystemMonitor.h
+ DisplayApp/Screens/Symbols.h
)
include_directories(
@@ -549,6 +551,8 @@ add_definitions(-DOS_CPUTIME_FREQ)
add_definitions(-DNRF52 -DNRF52832 -DNRF52832_XXAA -DNRF52_PAN_74 -DNRF52_PAN_64 -DNRF52_PAN_12 -DNRF52_PAN_58 -DNRF52_PAN_54 -DNRF52_PAN_31 -DNRF52_PAN_51 -DNRF52_PAN_36 -DNRF52_PAN_15 -DNRF52_PAN_20 -DNRF52_PAN_55 -DBOARD_PCA10040)
add_definitions(-DFREERTOS)
add_definitions(-DDEBUG_NRF_USER)
+add_definitions(-D__STACK_SIZE=8192)
+add_definitions(-D__HEAP_SIZE=8192)
if(NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE "Release")