summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJF <jf@codingfield.com>2020-07-02 21:38:52 +0200
committerJF <jf@codingfield.com>2020-07-02 21:38:52 +0200
commita83f067af9af82f034596f6f6154f4dccf598ace (patch)
treeb19b858f1b82a5eefe8f906f2d7cce253627ea77 /src/CMakeLists.txt
parent89e7033830bd73a35f4bb2faf14ccf06f3785712 (diff)
Reduce RAM memory usage by tuning the stack of the stasks and the heap allocated for FreeRTOS.
Add Monitor to log the stack usage of each task.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index a30fb568..8b39d2b5 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -442,6 +442,7 @@ set(INCLUDE_FILES
libs/date/includes/date/tz_private.h
DisplayApp/LittleVgl.h
SystemTask/SystemTask.h
+ SystemTask/SystemMonitor.h
)
include_directories(