summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJF <jf@codingfield.com>2019-12-05 19:23:46 +0100
committerJF <jf@codingfield.com>2019-12-05 19:23:46 +0100
commitadf405a2302bd1b3681f54d32f80a4bf441d2e3c (patch)
tree661abd353faa9bbb33049bd745451a181627f1b2 /src/CMakeLists.txt
parent66182d15bca7e88aaceee9bb4cc03218a4f24569 (diff)
Add support for LCD (ST7789)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 4d933367..5327fb1e 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -31,12 +31,16 @@ list(APPEND SOURCE_FILES
Logging/NrfLogger.cpp
BlinkApp/BlinkApp.cpp
main.cpp
+ drivers/st7789.cpp
+ drivers/spi_master_fast.cpp
)
set(INCLUDE_FILES
Logging/Logger.h
Logging/NrfLogger.h
BlinkApp/BlinkApp.h
+ drivers/st7789.h
+ drivers/spi_master_fast.h
)
nRF5x_addExecutable(pinetime-app "${SOURCE_FILES}") \ No newline at end of file