summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJF <jf@codingfield.com>2020-01-05 11:09:07 +0100
committerJF <jf@codingfield.com>2020-01-05 11:09:07 +0100
commitbbe4e500c3a972146d834d21dc355b8509f88342 (patch)
tree780ccd768997f93dd3fdc4db7d612e610bfb3bc0 /src/CMakeLists.txt
parent7688f468988ed26f522170bf0a5237ad974be02e (diff)
Improve power consumption and SLEEP mode :
- Disable IDLE hook (it would wake the device up as soon as possible). - Logger task sleep for 100ms (disable logging for better battery life) - Logging is disabled by default - Apply fix for ERRATA 87 (clear FPU interrupt before going to sleep). Ports files from FreeRTOS are now in the sources (they where in the SDK before)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 64014280..43ef24f1 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -42,6 +42,9 @@ list(APPEND SOURCE_FILES
Components/Ble/BleController.cpp
Components/DateTime/DateTimeController.cpp
drivers/Cst816s.cpp
+ FreeRTOS/port.c
+ FreeRTOS/port_cmsis_systick.c
+ FreeRTOS/port_cmsis.c
)
set(INCLUDE_FILES
@@ -59,6 +62,12 @@ set(INCLUDE_FILES
Components/Ble/BleController.h
Components/DateTime/DateTimeController.h
drivers/Cst816s.h
+ FreeRTOS/portmacro.h
+ FreeRTOS/portmacro_cmsis.h
+)
+
+include_directories(
+ FreeRTOS/
)
nRF5x_addExecutable(pinetime-app "${SOURCE_FILES}") \ No newline at end of file