summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJF <jf@codingfield.com>2020-07-04 13:58:15 +0200
committerJF <jf@codingfield.com>2020-07-04 13:58:15 +0200
commitda39f402e5b91c78b724bfe568efc9339459f5a2 (patch)
treed2508ce6eca43c29516feb4d2680cba17890af45 /src/CMakeLists.txt
parentbb11891b6e66efdc0a0fc8a9761d94719fd4748f (diff)
Replace bitmap icons by font icons (provided by AwesomeFont and LVGL). These icons are smaller in memory and quicker to draw.
BLE and battery icon replaced in Clock screen. Added heartbeat and step icons in Clock screen. Replace all labels in Menu by icons. Add doc to generate new font.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 776bd637..be73dbfb 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -363,7 +363,7 @@ list(APPEND SOURCE_FILES
${TINYCRYPT_SRC}
${NIMBLE_SRC}
${LVGL_SRC}
- ${IMAGE_FILES}
+ #${IMAGE_FILES}
${SDK_SOURCE_FILES}
DisplayApp/LittleVgl.cpp
@@ -443,6 +443,7 @@ set(INCLUDE_FILES
DisplayApp/LittleVgl.h
SystemTask/SystemTask.h
SystemTask/SystemMonitor.h
+ DisplayApp/Screens/Symbols.h
)
include_directories(