summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJF <jf@codingfield.com>2019-12-23 19:57:45 +0100
committerJF <jf@codingfield.com>2019-12-23 19:57:45 +0100
commite8f9304d37751e0344da4bd62183145235e071b5 (patch)
treecd122ecdb56800da077d20d453f465e74f878bc5 /src/CMakeLists.txt
parent981dc3fce1c63e79687307cbe5019c9116f7ab2d (diff)
Code cleaning, implement BT connection, advertising, discovery and CTS in ble_manager module.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index d2ba5e25..46c684ab 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -36,6 +36,7 @@ list(APPEND SOURCE_FILES
drivers/St7789.cpp
drivers/SpiMaster.cpp
Components/Gfx/Gfx.cpp
+ BLE/BleManager.c
)
set(INCLUDE_FILES
@@ -47,6 +48,7 @@ set(INCLUDE_FILES
drivers/St7789.h
drivers/SpiMaster.h
Components/Gfx/Gfx.h
+ BLE/BleManager.h
)
nRF5x_addExecutable(pinetime-app "${SOURCE_FILES}") \ No newline at end of file