summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJF002 <JF002@users.noreply.github.com>2020-11-17 19:13:29 +0100
committerGitHub <noreply@github.com>2020-11-17 19:13:29 +0100
commitf5aecb3e84d789c1ecaae4eda1baf987ad360a8e (patch)
treedc8d288b5f99fcc4781aa0707e024620b41876ec /src/CMakeLists.txt
parentf0e1f98823e41bfc2d9743fa8de70c882f26f93b (diff)
parenta30282bdd51aace465fa9b5b09759b99dba512d9 (diff)
Merge pull request #135 from ryanplusplus/flash-correct-file-with-jlink
Flash the correct file when running FLASH_pinetime-app with JLink
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 6c9ce24b..254fabcf 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -713,7 +713,7 @@ if (USE_JLINK)
)
add_custom_target("FLASH_${EXECUTABLE_NAME}"
DEPENDS ${EXECUTABLE_NAME}
- COMMAND ${NRFJPROG} --program ${EXECUTABLE_NAME}.hex -f ${NRF_TARGET} --sectorerase
+ COMMAND ${NRFJPROG} --program ${EXECUTABLE_FILE_NAME}.hex -f ${NRF_TARGET} --sectorerase
COMMAND sleep 0.5s
COMMAND ${NRFJPROG} --reset -f ${NRF_TARGET}
COMMENT "flashing ${EXECUTABLE_NAME}.hex"