summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJF <jf@codingfield.com>2020-03-22 12:03:17 +0100
committerJF <jf@codingfield.com>2020-03-22 12:03:17 +0100
commitfb64ba8fb6953fe7e98db6874207a687d0d57bac (patch)
tree786d1b187697c927dfcdb684da48e2feca80e0ce /src/CMakeLists.txt
parent8ed6ffaaf8d0ad681c4f84b89e4a72792edb5a8f (diff)
Add new App : Sysinfo. It displays various info about the running system : version, date/time, battery, brightness and resetreason. It contains placeholder for future use (like mac address, uptime,...).
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 34a7e250..5c521b33 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -213,6 +213,8 @@ list(APPEND SOURCE_FILES
DisplayApp/Screens/BatteryIcon.cpp
DisplayApp/Screens/BleIcon.cpp
DisplayApp/Screens/Brightness.cpp
+ DisplayApp/Screens/ScreenList.cpp
+ DisplayApp/Screens/Label.cpp
main.cpp
drivers/St7789.cpp
drivers/SpiMaster.cpp
@@ -253,7 +255,8 @@ set(INCLUDE_FILES
DisplayApp/Screens/BatteryIcon.h
DisplayApp/Screens/BleIcon.cpp
DisplayApp/Screens/Brightness.h
-# DisplayApp/Screens/Tab.h
+ DisplayApp/Screens/ScreenList.h
+ DisplayApp/Screens/Label.h
drivers/St7789.h
drivers/SpiMaster.h
drivers/Watchdog.h