summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt42
1 files changed, 9 insertions, 33 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index be8ef41f..75a6baa5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,28 +24,6 @@ if (NOT NRF5_SDK_PATH)
message(FATAL_ERROR "The path to the NRF52 SDK must be specified on the command line (add -DNRF5_SDK_PATH=<path>")
endif ()
-if(USE_JLINK)
- if (NOT NRFJPROG)
- message(FATAL_ERROR "the path to the tool nrfjprog must be specified on the command line (add -DNRFJPROG=<path>")
- endif ()
-endif()
-
-if(USE_GDB_CLIENT)
- if(NOT GDB_CLIENT_BIN_PATH)
- set(GDB_CLIENT_BIN_PATH "arm-none-eabi-gdb")
- endif()
-
- if(NOT GDB_CLIENT_TARGET_REMOTE)
- message(FATAL_ERROR "The GDB target must be specified (add -DGDB_CLIENT_TARGET_REMOTE=<target>")
- endif()
-endif()
-
-if(USE_OPENOCD)
- if(NOT OPENOCD_BIN_PATH)
- set(OPENOCD_BIN_PATH "openocd")
- endif()
-endif()
-
if(DEFINED USE_DEBUG_PINS AND USE_DEBUG_PINS)
add_definitions(-DUSE_DEBUG_PINS)
endif()
@@ -54,6 +32,10 @@ if(BUILD_DFU)
set(BUILD_DFU true)
endif()
+if(BUILD_RESOURCES)
+ set(BUILD_RESOURCES true)
+endif()
+
set(TARGET_DEVICE "PINETIME" CACHE STRING "Target device")
set_property(CACHE TARGET_DEVICE PROPERTY STRINGS PINETIME MOY-TFK5 MOY-TIN5 MOY-TON5 MOY-UNK)
@@ -77,17 +59,6 @@ message(" * Toolchain : " ${ARM_NONE_EABI_TOOLCHAIN_PATH})
message(" * GitRef(S) : " ${PROJECT_GIT_COMMIT_HASH})
message(" * NRF52 SDK : " ${NRF5_SDK_PATH})
message(" * Target device : " ${TARGET_DEVICE})
-set(PROGRAMMER "???")
-if(USE_JLINK)
- message(" * Programmer/debugger : JLINK")
- message(" * NrfJprog : " ${NRFJPROG})
-elseif(USE_GDB_CLIENT)
- message(" * Programmer/debugger : GDB Client")
- message(" * GDB Client path : " ${GDB_CLIENT_BIN_PATH})
- message(" * GDB Target : " ${GDB_CLIENT_TARGET_REMOTE})
-elseif(USE_OPENOCD)
- message(" * Programmer/debugger : OpenOCD Client")
-endif()
if(USE_DEBUG_PINS)
message(" * Debug pins : Enabled")
else()
@@ -98,6 +69,11 @@ if(BUILD_DFU)
else()
message(" * Build DFU (using adafruit-nrfutil) : Disabled")
endif()
+if(BUILD_RESOURCES)
+ message(" * Build resources : Enabled")
+else()
+ message(" * Build resources : Disabled")
+endif()
set(VERSION_EDIT_WARNING "// Do not edit this file, it is automatically generated by CMAKE!")
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/Version.h.in ${CMAKE_CURRENT_BINARY_DIR}/src/Version.h)