summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e799e878..3e36bff4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
cmake_minimum_required(VERSION 3.10)
-project(pinetime VERSION 0.2.2 LANGUAGES C CXX ASM)
+project(pinetime VERSION 0.3.0 LANGUAGES C CXX ASM)
set(NRF_TARGET "nrf52")
@@ -37,6 +37,10 @@ if(USE_OPENOCD)
endif()
endif()
+if(DEFINED USE_DEBUG_PINS AND USE_DEBUG_PINS)
+ add_definitions(-DUSE_DEBUG_PINS)
+endif()
+
message("BUILD CONFIGURATION")
message("-------------------")
message(" * Version : " ${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${PROJECT_VERSION_PATCH})
@@ -53,6 +57,11 @@ elseif(USE_GDB_CLIENT)
elseif(USE_OPENOCD)
message(" * Programmer/debugger : OpenOCD Client")
endif()
+if(USE_DEBUG_PINS)
+ message(" * Debug pins : Enabled")
+else()
+ message(" * Debug pins : Disabled")
+endif()
set(VERSION_EDIT_WARNING "// Do not edit this file, it is automatically generated by CMAKE!")
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/Version.h.in ${CMAKE_CURRENT_SOURCE_DIR}/src/Version.h)