summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 11 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a8d8426b..79b3dbe9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,9 +11,9 @@ if (NOT NRF5_SDK_PATH)
message(FATAL_ERROR "The path to the NRF52 SDK must be specified on the command line (add -DNRF5_SDK_PATH=<path>")
endif ()
-if(NOT USE_JLINK AND NOT USE_GDB_CLIENT)
- set(USE_JLINK true)
-endif()
+#if(NOT USE_JLINK AND NOT USE_GDB_CLIENT)
+# set(USE_JLINK true)
+#endif()
if(USE_JLINK)
if (NOT NRFJPROG)
@@ -31,6 +31,12 @@ if(USE_GDB_CLIENT)
endif()
endif()
+if(USE_OPENOCD)
+ if(NOT OPENOCD_BIN_PATH)
+ set(OPENOCD_BIN_PATH "openocd")
+ endif()
+endif()
+
message("BUILD CONFIGURATION")
message("-------------------")
message(" * Version : " ${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${PROJECT_VERSION_PATCH})
@@ -44,6 +50,8 @@ elseif(USE_GDB_CLIENT)
message(" * Programmer/debugger : GDB Client")
message(" * GDB Client path : " ${GDB_CLIENT_BIN_PATH})
message(" * GDB Target : " ${GDB_CLIENT_TARGET_REMOTE})
+elseif(USE_OPENOCD)
+ message(" * Programmer/debugger : OpenOCD Client")
endif()
set(VERSION_EDIT_WARNING "// Do not edit this file, it is automatically generated by CMAKE!")