summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4dc64ca4..eceb2122 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
cmake_minimum_required(VERSION 3.15)
-project(pinetime C CXX ASM)
+project(pinetime VERSION 0.0.2 LANGUAGES C CXX ASM)
set(NRF_TARGET "nrf52")
@@ -33,6 +33,7 @@ endif()
message("BUILD CONFIGURATION")
message("-------------------")
+message(" * Version : " ${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${PROJECT_VERSION_PATCH})
message(" * Toolchain : " ${ARM_NONE_EABI_TOOLCHAIN_PATH})
message(" * NRF52 SDK : " ${NRF5_SDK_PATH})
set(PROGRAMMER "???")
@@ -45,6 +46,8 @@ elseif(USE_GDB_CLIENT)
message(" * GDB Target : " ${GDB_CLIENT_TARGET_REMOTE})
endif()
+set(VERSION_EDIT_WARNING "// Do not edit this file, it is automatically generated by CMAKE!")
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/Version.h.in ${CMAKE_CURRENT_SOURCE_DIR}/src/Version.h)
include("cmake-nRF5x/CMake_nRF5x.cmake")
add_subdirectory(src)