summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 64014280..43ef24f1 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -42,6 +42,9 @@ list(APPEND SOURCE_FILES
Components/Ble/BleController.cpp
Components/DateTime/DateTimeController.cpp
drivers/Cst816s.cpp
+ FreeRTOS/port.c
+ FreeRTOS/port_cmsis_systick.c
+ FreeRTOS/port_cmsis.c
)
set(INCLUDE_FILES
@@ -59,6 +62,12 @@ set(INCLUDE_FILES
Components/Ble/BleController.h
Components/DateTime/DateTimeController.h
drivers/Cst816s.h
+ FreeRTOS/portmacro.h
+ FreeRTOS/portmacro_cmsis.h
+)
+
+include_directories(
+ FreeRTOS/
)
nRF5x_addExecutable(pinetime-app "${SOURCE_FILES}") \ No newline at end of file