summaryrefslogtreecommitdiff
path: root/tools/mcuboot/imgtool.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/mcuboot/imgtool.nix')
-rw-r--r--tools/mcuboot/imgtool.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/tools/mcuboot/imgtool.nix b/tools/mcuboot/imgtool.nix
new file mode 100644
index 00000000..7d750df4
--- /dev/null
+++ b/tools/mcuboot/imgtool.nix
@@ -0,0 +1,30 @@
+#
+# Nix environment for imgtool
+#
+# To install the environment
+#
+# $ nix-env --file imgtool.nix --install env-imgtool
+#
+# To load the environment
+#
+# $ load-env-imgtool
+#
+with import <nixpkgs> {};
+let
+ # Nixpkgs has fairly recent versions of the dependencies, so we can
+ # rely on them without having to build our own derivations.
+ imgtoolPythonEnv = python37.withPackages (
+ _: [
+ python37.pkgs.click
+ python37.pkgs.cryptography
+ python37.pkgs.intelhex
+ python37.pkgs.setuptools
+ python37.pkgs.cbor
+ ]
+ );
+in
+myEnvFun {
+ name = "imgtool";
+
+ buildInputs = [ imgtoolPythonEnv ];
+}