summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorIldar Mulyukov <ildar@altlinux.ru>2021-05-24 14:53:18 +0600
committerJF <JF002@users.noreply.github.com>2022-06-06 19:41:57 +0200
commit36740498db70eb3e38704906e66cd2f8a56bf319 (patch)
treef6d6fcc775714a52a0f874396552bdff86619e1e /CMakeLists.txt
parent5f28f89df2544846fb4144d85de9c0dc092301c7 (diff)
CMakeLists.txt: add double quotes in STRIP command
fixes cases when git is missing in the build system
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 55b68bc7..f6aaf62a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,7 +66,7 @@ execute_process(COMMAND git rev-parse --short HEAD
OUTPUT_VARIABLE PROJECT_GIT_COMMIT_HASH
RESULT_VARIABLE PROJECT_GIT_COMMIT_HASH_SUCCESS)
-string(STRIP ${PROJECT_GIT_COMMIT_HASH} PROJECT_GIT_COMMIT_HASH)
+string(STRIP "${PROJECT_GIT_COMMIT_HASH}" PROJECT_GIT_COMMIT_HASH)
message("PROJECT_GIT_COMMIT_HASH_SUCCESS? " ${PROJECT_GIT_COMMIT_HASH_SUCCESS})