summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorReinhold Gschweicher <pyro4hell@gmail.com>2022-01-17 21:25:16 +0100
committerReinhold Gschweicher <pyro4hell@gmail.com>2022-01-17 21:26:40 +0100
commit688dc2fed7b207bdf80b5f4af5a5df8faad9f2ec (patch)
tree06bc5e2c76f30c9b57dd6a2f3ce950f8d708c69e /CMakeLists.txt
parent26ae828e393d28390c5ea718bec9d4c1a96435ac (diff)
Create Version.h in binary dir instead of src dir
Don't use source directory for generated files. Use the binary (build) directory instead.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c2e0a114..8846531e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -100,7 +100,7 @@ else()
endif()
set(VERSION_EDIT_WARNING "// Do not edit this file, it is automatically generated by CMAKE!")
-configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/Version.h.in ${CMAKE_CURRENT_SOURCE_DIR}/src/Version.h)
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/Version.h.in ${CMAKE_CURRENT_BINARY_DIR}/src/Version.h)
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/docker/post_build.sh.in ${CMAKE_CURRENT_BINARY_DIR}/post_build.sh)