summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristoph Honal <christoph.honal@web.de>2022-05-10 21:46:36 +0200
committerRiku Isokoski <riksu9000@gmail.com>2022-06-27 08:28:48 +0300
commit8b0559c4812d74b6307757135622975523c5a88d (patch)
treead5a5f2e328f8d406a24e74c0d31d9ba2b723671 /CMakeLists.txt
parentbab86633a00c58ff01b7866cc600aabb2208b6e3 (diff)
Add basic hardware configuration options for P8
This enables the configuration of the LFCLK source, as well as the target hardware board pin configuration.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 2 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index acd48698..f49a9929 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -54,13 +54,8 @@ if(BUILD_DFU)
set(BUILD_DFU true)
endif()
-option(WATCH_COLMI_P8 "Build for the Colmi P8" OFF)
-set(TARGET_DEVICE "PineTime")
-
-if(WATCH_COLMI_P8)
- set(TARGET_DEVICE "Colmi P8")
- add_definitions(-DWATCH_P8)
-endif()
+set(TARGET_DEVICE "PINETIME" CACHE STRING "Target device")
+set_property(CACHE TARGET_DEVICE PROPERTY STRINGS PINETIME MOY-TFK5 MOY-TIN5 MOY-TON5 MOY-UNK)
set(PROJECT_GIT_COMMIT_HASH "")