summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRiku Isokoski <riksu9000@gmail.com>2022-12-30 23:31:31 +0200
committerRiku Isokoski <riksu9000@gmail.com>2023-01-24 10:43:17 +0200
commita3e14c012d76fc8f7ad4c16ad9dc67e8995ce10e (patch)
treeefd8d89f0d222d5db30e3cbd193e6d5f6111795b /CMakeLists.txt
parent8b0d888952bb3cfbf587ab20d5096f2e578a6107 (diff)
src: Enable unused parameter warning
Fix warnings. Some clang-formatting was necessary. DebugPins is unused and was removed.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 0 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index adb1754b..62c1637b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,10 +24,6 @@ if (NOT NRF5_SDK_PATH)
message(FATAL_ERROR "The path to the NRF52 SDK must be specified on the command line (add -DNRF5_SDK_PATH=<path>")
endif ()
-if(DEFINED USE_DEBUG_PINS AND USE_DEBUG_PINS)
- add_definitions(-DUSE_DEBUG_PINS)
-endif()
-
if(BUILD_DFU)
set(BUILD_DFU true)
endif()
@@ -59,11 +55,6 @@ message(" * Toolchain : " ${ARM_NONE_EABI_TOOLCHAIN_PATH})
message(" * GitRef(S) : " ${PROJECT_GIT_COMMIT_HASH})
message(" * NRF52 SDK : " ${NRF5_SDK_PATH})
message(" * Target device : " ${TARGET_DEVICE})
-if(USE_DEBUG_PINS)
- message(" * Debug pins : Enabled")
-else()
- message(" * Debug pins : Disabled")
-endif()
if(BUILD_DFU)
message(" * Build DFU (using adafruit-nrfutil) : Enabled")
else()