summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJF <jf@codingfield.com>2020-01-26 19:30:27 +0100
committerJF <jf@codingfield.com>2020-01-26 19:30:27 +0100
commitdff0d747c4252c17be182d4b25c4342b778ca65a (patch)
treebb696fb7709e5ff9e0ad961f5ced86882fef4ac3 /CMakeLists.txt
parent7c03810f46ff1f7accd2f5adb7404b4f2cb723d9 (diff)
parenta956ed1e61533854d460385336ace6f37c277a87 (diff)
Merge branch 'luben93-messing-with-openocd'
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a8d8426b..837bf11e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,7 +11,7 @@ if (NOT NRF5_SDK_PATH)
message(FATAL_ERROR "The path to the NRF52 SDK must be specified on the command line (add -DNRF5_SDK_PATH=<path>")
endif ()
-if(NOT USE_JLINK AND NOT USE_GDB_CLIENT)
+if(NOT USE_JLINK AND NOT USE_GDB_CLIENT AND NOT USE_OPENOCD)
set(USE_JLINK true)
endif()
@@ -31,6 +31,12 @@ if(USE_GDB_CLIENT)
endif()
endif()
+if(USE_OPENOCD)
+ if(NOT OPENOCD_BIN_PATH)
+ set(OPENOCD_BIN_PATH "openocd")
+ endif()
+endif()
+
message("BUILD CONFIGURATION")
message("-------------------")
message(" * Version : " ${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${PROJECT_VERSION_PATCH})
@@ -44,6 +50,8 @@ elseif(USE_GDB_CLIENT)
message(" * Programmer/debugger : GDB Client")
message(" * GDB Client path : " ${GDB_CLIENT_BIN_PATH})
message(" * GDB Target : " ${GDB_CLIENT_TARGET_REMOTE})
+elseif(USE_OPENOCD)
+ message(" * Programmer/debugger : OpenOCD Client")
endif()
set(VERSION_EDIT_WARNING "// Do not edit this file, it is automatically generated by CMAKE!")