summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJean-François Milants <jf@codingfield.com>2022-09-11 12:43:30 +0200
committerJF <JF002@users.noreply.github.com>2022-09-11 14:44:36 +0200
commite2a3d9f0c7a531d129501325e793fdd634babba8 (patch)
tree761da8923c45bbad0b8c31fcfe72fb015198dcc3 /CMakeLists.txt
parentcbe2f08cf7e9cd7bbfe3162e254db9648460ae58 (diff)
Small improvement in generate-fonts.py following code review.
Add lv_img_conf in Docker image to build resources at build time.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index be8ef41f..1da460c4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -54,6 +54,10 @@ if(BUILD_DFU)
set(BUILD_DFU true)
endif()
+if(BUILD_RESOURCES)
+ set(BUILD_RESOURCES true)
+endif()
+
set(TARGET_DEVICE "PINETIME" CACHE STRING "Target device")
set_property(CACHE TARGET_DEVICE PROPERTY STRINGS PINETIME MOY-TFK5 MOY-TIN5 MOY-TON5 MOY-UNK)
@@ -98,6 +102,11 @@ if(BUILD_DFU)
else()
message(" * Build DFU (using adafruit-nrfutil) : Disabled")
endif()
+if(BUILD_RESOURCES)
+ message(" * Build resources : Enabled")
+else()
+ message(" * Build resources : Disabled")
+endif()
set(VERSION_EDIT_WARNING "// Do not edit this file, it is automatically generated by CMAKE!")
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/Version.h.in ${CMAKE_CURRENT_BINARY_DIR}/src/Version.h)