summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorhubmartin <hub.martin@gmail.com>2021-09-13 11:41:51 +0200
committerhubmartin <hub.martin@gmail.com>2021-09-13 11:41:51 +0200
commite614af1c4a53e943256b3b2acee4bfe7d7204bbf (patch)
treef7570c7a0ec1683ce4279b8f39bb2c45ea35f29a /CMakeLists.txt
parent73d3e41ceadf576542508c114679e1d3e6039d4d (diff)
Add WATCH_COLMI_P8 option to cmake & docs
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cc41a087..f2402e57 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -51,6 +51,14 @@ if(BUILD_DFU)
set(BUILD_DFU true)
endif()
+option(WATCH_COLMI_P8 "Build for the Colmi P8" OFF)
+set(TARGET_DEVICE "PineTime")
+
+if(WATCH_COLMI_P8)
+ set(TARGET_DEVICE "Colmi P8")
+ add_definitions(-DWATCH_P8)
+endif()
+
set(PROJECT_GIT_COMMIT_HASH "")
execute_process(COMMAND git rev-parse --short HEAD
@@ -68,6 +76,7 @@ message(" * Version : " ${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${P
message(" * Toolchain : " ${ARM_NONE_EABI_TOOLCHAIN_PATH})
message(" * GitRef(S) : " ${PROJECT_GIT_COMMIT_HASH})
message(" * NRF52 SDK : " ${NRF5_SDK_PATH})
+message(" * Target device : " ${TARGET_DEVICE})
set(PROGRAMMER "???")
if(USE_JLINK)
message(" * Programmer/debugger : JLINK")