summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJF <jf@codingfield.com>2020-02-23 13:44:39 +0100
committerJF <jf@codingfield.com>2020-02-23 13:44:39 +0100
commit02772b996fb26146cf38fc6deccff7f43a49dfd6 (patch)
treef2ff90c577f68ccb44b6470621bf87e68a49aed8 /src/CMakeLists.txt
parent2bdff7ed2b490cb8ce5599341e12d707c0ba7fd0 (diff)
Do not compile GFX and older fonts anymore.
Refactor SystemTask in its own class. Refactor Screen to be able to close current screen and open a new one. Re-enable sleep/wake up and propagate button event to Screens.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt19
1 files changed, 9 insertions, 10 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index a5971f27..efbb3861 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -156,17 +156,15 @@ list(APPEND SOURCE_FILES
Logging/NrfLogger.cpp
BlinkApp/BlinkApp.cpp
DisplayApp/DisplayApp.cpp
- DisplayApp/Fonts/lcdfont70.c
- DisplayApp/Fonts/lcdfont14.c
DisplayApp/Screens/Screen.cpp
DisplayApp/Screens/Clock.cpp
- DisplayApp/Screens/Message.cpp
+# DisplayApp/Screens/Message.cpp
DisplayApp/Screens/Tile.cpp
- DisplayApp/Screens/Tab.cpp
+# DisplayApp/Screens/Tab.cpp
main.cpp
drivers/St7789.cpp
drivers/SpiMaster.cpp
- Components/Gfx/Gfx.cpp
+# Components/Gfx/Gfx.cpp
BLE/BleManager.c
Components/Battery/BatteryController.cpp
Components/Ble/BleController.cpp
@@ -180,6 +178,8 @@ list(APPEND SOURCE_FILES
DisplayApp/LittleVgl.cpp
DisplayApp/Fonts/jetbrains_mono_extrabold_compressed.c
DisplayApp/Fonts/jetbrains_mono_bold_20.c
+
+ SystemTask/SystemTask.cpp
)
set(INCLUDE_FILES
@@ -187,16 +187,13 @@ set(INCLUDE_FILES
Logging/NrfLogger.h
BlinkApp/BlinkApp.h
DisplayApp/DisplayApp.h
- DisplayApp/Fonts/lcdfont70.h
- DisplayApp/Fonts/lcdfont14.h
DisplayApp/Screens/Screen.h
DisplayApp/Screens/Clock.h
- DisplayApp/Screens/Message.h
+# DisplayApp/Screens/Message.h
DisplayApp/Screens/Tile.h
- DisplayApp/Screens/Tab.h
+# DisplayApp/Screens/Tab.h
drivers/St7789.h
drivers/SpiMaster.h
- Components/Gfx/Gfx.h
BLE/BleManager.h
Components/Battery/BatteryController.h
Components/Ble/BleController.h
@@ -214,6 +211,8 @@ set(INCLUDE_FILES
libs/date/includes/date/tz_private.h
DisplayApp/LittleVgl.h
+
+ SystemTask/SystemTask.h
)
include_directories(