summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJF002 <JF002@users.noreply.github.com>2020-10-30 14:16:04 +0100
committerGitHub <noreply@github.com>2020-10-30 14:16:04 +0100
commit0e97db1c30748d9893291a27504bb55723f58e7d (patch)
tree9b410aee92af82099619c56a4d25c9c6b7c99e68 /src/CMakeLists.txt
parentcb9e8815d8bc6ce71fd8e97f3e3dae402658ce1f (diff)
parent29f8074fcb844cf9668a5bf071e9cffa47299c99 (diff)
Merge pull request #118 from JF002/improve-ble-connection
Improve ble connection
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 4d691ede..6c9ce24b 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -369,6 +369,7 @@ list(APPEND SOURCE_FILES
components/ble/MusicService.cpp
components/ble/BatteryInformationService.cpp
components/ble/ImmediateAlertService.cpp
+ components/ble/ServiceDiscovery.cpp
components/firmwarevalidator/FirmwareValidator.cpp
drivers/Cst816s.cpp
FreeRTOS/port.c
@@ -447,6 +448,8 @@ set(INCLUDE_FILES
components/firmwarevalidator/FirmwareValidator.h
components/ble/BatteryInformationService.h
components/ble/ImmediateAlertService.h
+ components/ble/ServiceDiscovery.h
+ components/ble/BleClient.h
drivers/Cst816s.h
FreeRTOS/portmacro.h
FreeRTOS/portmacro_cmsis.h