summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJF <jf@codingfield.com>2020-10-27 19:38:45 +0100
committerJF <jf@codingfield.com>2020-10-27 19:38:45 +0100
commit1bb2eb9dcd59fbb198be157e34b7ff25367adea0 (patch)
tree6bebf5630cedb1cf0476e590563964616d8dc456 /src/CMakeLists.txt
parentab7acd0f076899fafb1cb5ff233a9c6b6b1ca15b (diff)
Disable sleep mode on the SPI NOR Flash when the version is unknown. This is because the current bootloader (which does not exposes its version) cannot initialize the chip when it's in sleep mode.
This feature will be re-enabled when the bootloader expses it's version.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index cd37810f..af0b110e 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -322,6 +322,7 @@ list(APPEND IMAGE_FILES
)
list(APPEND SOURCE_FILES
+ BootloaderVersion.cpp
logging/NrfLogger.cpp
displayapp/DisplayApp.cpp
displayapp/screens/Screen.cpp
@@ -397,6 +398,7 @@ list(APPEND GRAPHICS_SOURCE_FILES
)
set(INCLUDE_FILES
+ BootloaderVersion.h
logging/Logger.h
logging/NrfLogger.h
displayapp/DisplayApp.h