summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJF <jf@codingfield.com>2020-03-15 20:19:29 +0100
committerGitea <gitea@fake.local>2020-03-15 20:19:29 +0100
commit2c55ab20b4f52d21a04e1d0ee049f7c4ca0196de (patch)
treed51123b57241556303891ef4cb5b81c47c348a51 /src/CMakeLists.txt
parenteabb54f15df7df69951ce8f49a62d3bd702dd686 (diff)
parent2ed76ac55615a720dbcbf2ac828ad3060a252273 (diff)
Merge branch 'brightness-app' of JF/PineTime into develop
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index a957e104..670f0630 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -161,6 +161,11 @@ set(LVGL_SRC
libs/lvgl/src/lv_objx/lv_mbox.c
libs/lvgl/src/lv_objx/lv_mbox.h
+ libs/lvgl/src/lv_objx/lv_bar.c
+ libs/lvgl/src/lv_objx/lv_bar.h
+ libs/lvgl/src/lv_objx/lv_slider.h
+ libs/lvgl/src/lv_objx/lv_slider.c
+
)
list(APPEND IMAGE_FILES
@@ -207,7 +212,7 @@ list(APPEND SOURCE_FILES
DisplayApp/Screens/Modal.cpp
DisplayApp/Screens/BatteryIcon.cpp
DisplayApp/Screens/BleIcon.cpp
-
+ DisplayApp/Screens/Brightness.cpp
main.cpp
drivers/St7789.cpp
drivers/SpiMaster.cpp
@@ -217,6 +222,7 @@ list(APPEND SOURCE_FILES
Components/Battery/BatteryController.cpp
Components/Ble/BleController.cpp
Components/DateTime/DateTimeController.cpp
+ Components/Brightness/BrightnessController.cpp
drivers/Cst816s.cpp
FreeRTOS/port.c
FreeRTOS/port_cmsis_systick.c
@@ -245,6 +251,7 @@ set(INCLUDE_FILES
DisplayApp/Screens/Modal.h
DisplayApp/Screens/BatteryIcon.h
DisplayApp/Screens/BleIcon.cpp
+ DisplayApp/Screens/Brightness.h
# DisplayApp/Screens/Tab.h
drivers/St7789.h
drivers/SpiMaster.h
@@ -254,6 +261,7 @@ set(INCLUDE_FILES
Components/Battery/BatteryController.h
Components/Ble/BleController.h
Components/DateTime/DateTimeController.h
+ Components/Brightness/BrightnessController.h
drivers/Cst816s.h
FreeRTOS/portmacro.h
FreeRTOS/portmacro_cmsis.h