summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJF <jf@codingfield.com>2020-05-24 20:30:06 +0200
committerJF <jf@codingfield.com>2020-05-24 20:30:06 +0200
commit4717cf0a1d6c210a362e8bdf63265c4910e2c8cc (patch)
tree910a75143df2fa141451b419d26470a060b748c4 /src/CMakeLists.txt
parent00451ef05b7b793c7cd098cc3834c6874c51e56e (diff)
Add driver for writing into the internal flash.
Write the OK flag for mcuboot using this driver.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 023c4ee6..c0a46ed0 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -342,6 +342,7 @@ list(APPEND SOURCE_FILES
drivers/Spi.cpp
drivers/Watchdog.cpp
drivers/DebugPins.cpp
+ drivers/InternalFlash.cpp
Components/Battery/BatteryController.cpp
Components/Ble/BleController.cpp
Components/Ble/NotificationManager.cpp
@@ -396,6 +397,7 @@ set(INCLUDE_FILES
drivers/Spi.h
drivers/Watchdog.h
drivers/DebugPins.h
+ drivers/InternalFlash.h
Components/Battery/BatteryController.h
Components/Ble/BleController.h
Components/Ble/NotificationManager.h