summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJF <JF002@users.noreply.github.com>2021-10-24 20:06:52 +0200
committerGitHub <noreply@github.com>2021-10-24 20:06:52 +0200
commit82ca526ec2db11d9e4aa2d91cd69ed2394e3a843 (patch)
treeaf91df7395abd8bed0d12c276b3703f46cbfadfd /src/CMakeLists.txt
parent9538eb97166410ebc362addfb76ec54895491cd7 (diff)
parentb3a82288997556b04a64d452ec2067747f1fb706 (diff)
Merge pull request #754 from InfiniTimeOrg/add-motion-service
Add motion service
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 07eabe11..a839e080 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -477,6 +477,7 @@ list(APPEND SOURCE_FILES
components/ble/ImmediateAlertService.cpp
components/ble/ServiceDiscovery.cpp
components/ble/HeartRateService.cpp
+ components/ble/MotionService.cpp
components/firmwarevalidator/FirmwareValidator.cpp
components/motor/MotorController.cpp
components/settings/Settings.cpp
@@ -545,6 +546,7 @@ list(APPEND RECOVERY_SOURCE_FILES
components/ble/ServiceDiscovery.cpp
components/ble/NavigationService.cpp
components/ble/HeartRateService.cpp
+ components/ble/MotionService.cpp
components/firmwarevalidator/FirmwareValidator.cpp
components/settings/Settings.cpp
components/timer/TimerController.cpp
@@ -652,6 +654,7 @@ set(INCLUDE_FILES
components/ble/ServiceDiscovery.h
components/ble/BleClient.h
components/ble/HeartRateService.h
+ components/ble/MotionService.h
components/settings/Settings.h
components/timer/TimerController.h
components/alarm/AlarmController.h