summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJF <jf@codingfield.com>2020-08-11 17:50:00 +0200
committerJF <jf@codingfield.com>2020-08-11 17:50:00 +0200
commitbbfc20c3ff4b741cd21b162389905a59a8e22f3f (patch)
tree75b8e00398b14aa8b887013e93adcb0edecfe75f /src/CMakeLists.txt
parent27fa273d8315f972931dba7971a99b0fbba7360e (diff)
Add new screen that allows the user to manually validate the new firmware he's just OTA'ed.
Still need to find a way to display this screen when needed.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 2d6d6e8e..10c28189 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -337,6 +337,7 @@ list(APPEND SOURCE_FILES
DisplayApp/Screens/Label.cpp
DisplayApp/Screens/FirmwareUpdate.cpp
DisplayApp/Screens/Music.cpp
+ DisplayApp/Screens/FirmwareValidation.cpp
main.cpp
drivers/St7789.cpp
drivers/SpiNorFlash.cpp
@@ -358,6 +359,7 @@ list(APPEND SOURCE_FILES
Components/Ble/CurrentTimeService.cpp
Components/Ble/AlertNotificationService.cpp
Components/Ble/MusicService.cpp
+ Components/FirmwareValidator/FirmwareValidator.cpp
drivers/Cst816s.cpp
FreeRTOS/port.c
FreeRTOS/port_cmsis_systick.c
@@ -415,6 +417,7 @@ set(INCLUDE_FILES
DisplayApp/Screens/ScreenList.h
DisplayApp/Screens/Label.h
DisplayApp/Screens/FirmwareUpdate.h
+ DisplayApp/Screens/FirmwareValidation.h
drivers/St7789.h
drivers/SpiNorFlash.h
drivers/SpiMaster.h
@@ -432,7 +435,8 @@ set(INCLUDE_FILES
Components/Ble/CurrentTimeClient.h
Components/Ble/AlertNotificationClient.h
Components/Ble/DfuService.h
- drivers/Cst816s.h
+ Components/FirmwareValidator/FirmwareValidator.h
+ drivers/Cst816s.h
FreeRTOS/portmacro.h
FreeRTOS/portmacro_cmsis.h
libs/date/includes/date/tz.h