summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 00000000..4d933367
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,42 @@
+cmake_minimum_required(VERSION 3.12)
+
+project(pinetime-app C CXX ASM)
+
+# define some variables just for this example to determine file locations
+set(NRF_PROJECT_NAME pinetime-app)
+set(NRF_BOARD pca10040)
+#set(NRF_SOFTDEVICE s132)
+
+nRF5x_toolchainSetup()
+nRF5x_setup()
+
+#nRF5x_addAppScheduler()
+#nRF5x_addAppFIFO()
+#nRF5x_addAppTimer()
+#nRF5x_addAppUART()
+nRF5x_addAppButton()
+nRF5x_addBSP(FALSE FALSE FALSE)
+nRF5x_addAppGpiote()
+#nRF5x_addBLEGATT()
+#
+#nRF5x_addBLEService(ble_lbs)
+
+add_definitions(-DCONFIG_GPIO_AS_PINRESET)
+add_definitions(-DDEBUG)
+
+
+include_directories(.)
+
+list(APPEND SOURCE_FILES
+ Logging/NrfLogger.cpp
+ BlinkApp/BlinkApp.cpp
+ main.cpp
+)
+
+set(INCLUDE_FILES
+ Logging/Logger.h
+ Logging/NrfLogger.h
+ BlinkApp/BlinkApp.h
+)
+
+nRF5x_addExecutable(pinetime-app "${SOURCE_FILES}") \ No newline at end of file