summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRiku Isokoski <riksu9000@gmail.com>2021-09-13 21:22:53 +0300
committerGitHub <noreply@github.com>2021-09-13 21:22:53 +0300
commit40765f117347f4a4fc6cc4d2c4e46b1923a18fbb (patch)
treef1eac679b683e04b80fdd245dd9d4c6949a174a5 /CMakeLists.txt
parent3ee4876214b70c107cabbb54f865e646e99f0d73 (diff)
parentb0bdd2be1c30d349a1efef96b93a5771f5edbd06 (diff)
Merge branch 'develop' into disable_notif_only
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cc41a087..f2402e57 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -51,6 +51,14 @@ if(BUILD_DFU)
set(BUILD_DFU true)
endif()
+option(WATCH_COLMI_P8 "Build for the Colmi P8" OFF)
+set(TARGET_DEVICE "PineTime")
+
+if(WATCH_COLMI_P8)
+ set(TARGET_DEVICE "Colmi P8")
+ add_definitions(-DWATCH_P8)
+endif()
+
set(PROJECT_GIT_COMMIT_HASH "")
execute_process(COMMAND git rev-parse --short HEAD
@@ -68,6 +76,7 @@ message(" * Version : " ${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${P
message(" * Toolchain : " ${ARM_NONE_EABI_TOOLCHAIN_PATH})
message(" * GitRef(S) : " ${PROJECT_GIT_COMMIT_HASH})
message(" * NRF52 SDK : " ${NRF5_SDK_PATH})
+message(" * Target device : " ${TARGET_DEVICE})
set(PROGRAMMER "???")
if(USE_JLINK)
message(" * Programmer/debugger : JLINK")