summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJF002 <JF002@users.noreply.github.com>2021-09-13 20:05:43 +0200
committerGitHub <noreply@github.com>2021-09-13 20:05:43 +0200
commitb0bdd2be1c30d349a1efef96b93a5771f5edbd06 (patch)
treef87b3c1b7b2fb664bc26da96f4cafd0206aa53dc /CMakeLists.txt
parent84a93b54410681ce1aaae80ba7a7e6d3300dcfa1 (diff)
parente614af1c4a53e943256b3b2acee4bfe7d7204bbf (diff)
Merge pull request #549 from hubmartin/pinmap
Put all duplicated GPIO pin definitions to a single file
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cc41a087..f2402e57 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -51,6 +51,14 @@ if(BUILD_DFU)
set(BUILD_DFU true)
endif()
+option(WATCH_COLMI_P8 "Build for the Colmi P8" OFF)
+set(TARGET_DEVICE "PineTime")
+
+if(WATCH_COLMI_P8)
+ set(TARGET_DEVICE "Colmi P8")
+ add_definitions(-DWATCH_P8)
+endif()
+
set(PROJECT_GIT_COMMIT_HASH "")
execute_process(COMMAND git rev-parse --short HEAD
@@ -68,6 +76,7 @@ message(" * Version : " ${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${P
message(" * Toolchain : " ${ARM_NONE_EABI_TOOLCHAIN_PATH})
message(" * GitRef(S) : " ${PROJECT_GIT_COMMIT_HASH})
message(" * NRF52 SDK : " ${NRF5_SDK_PATH})
+message(" * Target device : " ${TARGET_DEVICE})
set(PROGRAMMER "???")
if(USE_JLINK)
message(" * Programmer/debugger : JLINK")